Welkom  

   

Mijn Menu  

   

What's Up  

Geen evenementen
   

Wedstrijd  

Geen evenementen
   
   
   
   
   
   
   
   
   
   
   
   
   
   
Welkom, Gasten
  • Pagina:
  • 1
  • 2

Onderwerp: AIS werkt slechter als GPS is ingeschakeld

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 10:34 #1245764

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
Zondag heb ik op een rpi 4, 4Gb debian Raspios 64 bits geïnstalleerd.
Daarop heb ik Openplotter geïnstalleerd, dat lukte allemaal prima.

Zo heb ik ook een AIS usb dongle (zo'n blauw ding) aangesloten en dan ontvang ik van veel schepen de positie ed. Dan update hij ook vaak.

Ik heb ook een GPS usb muis en ook die werkt op zich prima als ik die activeer.
Alleen als ik deze activeer (in opencpn bij verbindingen, "inschakelen") dan ontvang ik ineens van nog maar enkele schepen ais info. En het lijkt dat het updaten ook veel minder frequent is.

Ik kan dat heel simpel reproduceren door de GPS in of uit te schakelen (hij blijft dus aangesloten op de usb poort).

Wat zou dat kunnen zijn?
Laatst bewerkt: 19 jan 2021 10:45 door lschip.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 10:44 #1245772

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 2121
2 gps'en die door elkaar praten, de AIS levert ook GPS data.
Bert
Spækhugger
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 10:48 #1245783

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
lschip schreef :
Zondag heb ik op een rpi 4, 4Gb debian Raspios 64 bits geïnstalleerd.
Daarop heb ik Openplotter geïnstalleerd, dat lukte allemaal prima.

Zo heb ik ook een AIS usb dongle (zo'n blauw ding) aangesloten en dan ontvang ik van veel schepen de positie ed. Dan update hij ook vaak.

Ik heb ook een GPS usb muis en ook die werkt op zich prima als ik die activeer.
Alleen als ik deze activeer (in opencpn bij verbindingen, "inschakelen") dan ontvang ik ineens van nog maal enkele schepen ais info. En het lijkt dat het updaten ook veel minder frequent is.

Ik kan dat heel simpel reproduceren door de GPS in of uit te schakelen (hij blijft dus aangesloten op de usb poort).

Wat zou dat kunnen zijn?

De inkomende data in de SignalK server zetten. Die is er juist voor om het data verkeer te verwerken en te multiplexen.

het handigste doe je dat via Serial van OpenPlotter. Daar staan de verbindingen al in.
Per verbinding activeren en een naam (alias) geven. Zodat ze herkend worden ongeacht de usb poort waar je ze insteekt. Werkt ook met een USB hub.

Daarna in verbindingen aangeven verplaatsen naar SignalK. Dan komt de vraag over de baudrate. En de SignalK server herstart.

In OpenCPN maak je alleen een verbinding met de SignalK server:

invoer netwerk: signalk localhost poort 3000

Uiteraard moet je de SignalK server via OpenPlotter installeren. Is ook erg eenvoudig.

Bram

Zou nog kunnen dat je AIS dongle teveel stroom trekt. Dan moet je naar een actieve usb hub.
Laatst bewerkt: 19 jan 2021 10:51 door brambo.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 10:48 #1245784

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
Knoet schreef :
2 gps'en die door elkaar praten, de AIS levert ook GPS data.

Dat snap ik niet. Ik snap dat in de AIS data gps gegevens zitten van andere schepen. maar niet van mijn eigen positie (ik heb geen ais zender).

Dat conflicteert dan toch niet.
En een combinatie van een ais ontvanger en een gps ontvanger zou toch moeten kunnen (hoe anders)?
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 10:55 #1245787

  • Calidris
  • Calidris's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 27422
EMC probleem?

Ik denk dat de dongle storing ontvangt vanuit de GPS muis. Zelfs de USB voeding op het PI-board kan dat al zijn.
Zou mogelijk kinnen zijn dat de USB 5 volt geen 5 volt is en nog verder zakt onder de 4,75 volt?

- Zorg dat je AIS antenne buiten staat en ver van de PI
- Gebruik een échte AIS ontvanger ipv een SDR stick.

SDR sticks of dongles leveren géén GPS data (als ze AIS ontvangen)
ZF informatie kanaal Telegram: t.me/zeilersforum
Laatst bewerkt: 19 jan 2021 10:56 door Calidris.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:04 #1245788

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
WADnWIND schreef :
EMC probleem?

Ik denk dat de dongle storing ontvangt vanuit de GPS muis. Zelfs de USB voeding op het PI-board kan dat al zijn.
Zou mogelijk kinnen zijn dat de USB 5 volt geen 5 volt is en nog verder zakt onder de 4,75 volt?

Mij lijkt dit niet het probleem omdat ik beide aangesloten heb en alleen als ik in OpenCPN "inschakelen" aanklik het probleem ontstaat. Ik neem aan dat ook bij "uitgeschakeld" in Opencpn de GPS muis nog steeds stroom krijgt. Maar ik kan het nameten.

De afstand tussen AIS antenne en GPS muis is idd klein +/- 1 meter.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:09 #1245790

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
OpenCPN moet dan Ais data met een bepaalde baudrate en de GPSmuis combineren.

Kun je beter door de data server laten doen en een gecombineerde invoer naar OpenCPN.

Lijkt mij logisch.

Bram
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:13 #1245792

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
brambo schreef :
OpenCPN moet dan Ais data met een bepaalde baudrate en de GPSmuis combineren.

Kun je beter door de data server laten doen en een gecombineerde invoer naar OpenCPN.

Lijkt mij logisch.

Bram

Je bedoelt in Signal K? Dat zou ook mijn voorkeur hebben.
Volgens mij moet ik dan eerst GPSD in linux installeren en dan loop ik tegen een ander probleem aan, de CPU gaat dan naar 100% als ik de GPS muis aansluit. Dan kan ik niets meer doen, zelfs geen ssh sessie meer starten.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:14 #1245794

  • rooiedirk
  • rooiedirk's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 6499
Kijk eens in het nmea-debug venster (OpenCPN) wat er gebeurd als je de gps ook inschakeld. Maak evt een kopietje en post het hier.

Let er met name op of dezelde nmea regel meerdere keren herhaald wordt.
Laatst bewerkt: 19 jan 2021 11:17 door rooiedirk.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:26 #1245795

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
rooiedirk schreef :
Kijk eens in het nmea-debug venster (OpenCPN) wat er gebeurd als je de gps ook inschakeld. Maak evt een kopietje en post het hier.

Let er met name op of dezelde nmea regel meerdere keren herhaald wordt.

Bedoel je dit?
Laatst bewerkt: 19 jan 2021 11:27 door lschip.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:35 #1245798

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
Kan gewoon serieel in de meeste gevallen. Betreffende aansluiting staat dan al in Serial.
lschip schreef :
brambo schreef :
OpenCPN moet dan Ais data met een bepaalde baudrate en de GPSmuis combineren.

Kun je beter door de data server laten doen en een gecombineerde invoer naar OpenCPN.

Lijkt mij logisch.

Bram

Je bedoelt in Signal K? Dat zou ook mijn voorkeur hebben.
Volgens mij moet ik dan eerst GPSD in linux installeren en dan loop ik tegen een ander probleem aan, de CPU gaat dan naar 100% als ik de GPS muis aansluit. Dan kan ik niets meer doen, zelfs geen ssh sessie meer starten.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:37 #1245800

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 2121
Zo te zien heb je in openCPN output naar ttyACM0 aan staan, waarom is dat?
Bert
Spækhugger
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:54 #1245808

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
Knoet schreef :
Zo te zien heb je in openCPN output naar ttyACM0 aan staan, waarom is dat?

ja, dat slaat nergens op, is een foutje. Maar het probleem blijft bestaan als ik de output uitschakel.

Nmea debug:



De verbindingen:
Laatst bewerkt: 19 jan 2021 11:56 door lschip.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 11:59 #1245811

  • Arcadia
  • Arcadia's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 2745
lschip schreef :
Ik snap dat in de AIS data gps gegevens zitten van andere schepen. maar niet van mijn eigen positie (ik heb geen ais zender).

Als de AIS gegevens levert over CPA en TCPA, dan moet hij toch ook over de eigen positie beschikken?
privé: www.sailingarcadia.nl
zeilclub: www.czt.nl, voor schippers én opstappers
Religie is de oudste complottheorie
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:04 #1245815

EN minimaal ook COG/SOG
Contest 36s Camelot
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:16 #1245825

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 2121
Het blijkt om een AIS ontvanger te gaan, dus geen positie/SOG/COG. Maar in het stukje debugdata zie ik helemaal geen VDM berichten van je AIS ontvanger. Zie je er daar meer van als de GPS er niet aan zit?

[Edit]: O wacht, die komen vast via SignalK en daardoor zie je ze niet in het debug venster. Vraag was dus niet relevant.
Bert
Spækhugger
Laatst bewerkt: 19 jan 2021 12:24 door Knoet.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:23 #1245829

  • henkvd
  • henkvd's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 3992
kan je GPGSV niet blokkeren die vreet al je halve beschikbare ruimte op en voegt verder niets toe.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:26 #1245831

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
lschip schreef :
Knoet schreef :
Zo te zien heb je in openCPN output naar ttyACM0 aan staan, waarom is dat?

ja, dat slaat nergens op, is een foutje. Maar het probleem blijft bestaan als ik de output uitschakel.

Nmea debug:



De verbindingen:

SignalK server adres moet zijn signalk localhost 3000. Vinkje automatische server uitzetten.

En de muis ook in SignalK zetten. Dan komt de gemultiplexte data naar OpenCPN.
Laatst bewerkt: 19 jan 2021 12:27 door brambo.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:50 #1245838

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
henkvd schreef :
kan je GPGSV niet blokkeren die vreet al je halve beschikbare ruimte op en voegt verder niets toe.

Als ik die blokkeer maakt dat niet uit. Probleem blijft.
brambo schreef :
SignalK server adres moet zijn signalk localhost 3000. Vinkje automatische server uitzetten.
Heb ik nu aangepast maar dat maakt ook niet uit.
brambo schreef :
En de muis ook in SignalK zetten. Dan komt de gemultiplexte data naar OpenCPN.
Dan moet ik volgens mij GPSD installeren (sudo apt-get install gpsd) en dan gaat de CPU naar 100%. Waarom weet ik ook niet.
Laatst bewerkt: 19 jan 2021 12:50 door lschip.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 12:54 #1245839

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
lschip schreef :
henkvd schreef :
kan je GPGSV niet blokkeren die vreet al je halve beschikbare ruimte op en voegt verder niets toe.

Als ik die blokkeer maakt dat niet uit. Probleem blijft.
brambo schreef :
SignalK server adres moet zijn signalk localhost 3000. Vinkje automatische server uitzetten.
Heb ik nu aangepast maar dat maakt ook niet uit.
brambo schreef :
En de muis ook in SignalK zetten. Dan komt de gemultiplexte data naar OpenCPN.
Dan moet ik volgens mij GPSD installeren (sudo apt-get install gpsd) en dan gaat de CPU naar 100%. Waarom weet ik ook niet.

je kunt serieel gewoon invoeren in Serial van OpenPlotter GPSD kan ook. Zit al standaard in OpenPlotter.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 13:08 #1245842

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
brambo schreef :
je kunt serieel gewoon invoeren in Serial van OpenPlotter GPSD kan ook. Zit al standaard in OpenPlotter.

Dat lijkt mij ook het mooiste, dus ook zonder installatie van GPSD.
Als ik dat probeer krijg ik dit:


Laatst bewerkt: 19 jan 2021 13:11 door lschip.
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 13:17 #1245845

  • Calidris
  • Calidris's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 27422
brambo schreef :
OpenCPN moet dan Ais data met een bepaalde baudrate en de GPSmuis combineren.

Kun je beter door de data server laten doen en een gecombineerde invoer naar OpenCPN.

Lijkt mij logisch.

Bram

Bram,

Wat is je gefundeerde grond voor deze opmerking?
Als het aantal AIS doelen afneemt, heeft dat niets met het combineeren te maken. Of wil je zeggen dat Opencpn te veel rekenkracht vraagt waardoor er data gemist wordt?
In dat geval is een RPI de verkeerde hardware.

Qua AIS presentatie mag het dus niet uitmaken in aantal doelen wat je ook doet.
ZF informatie kanaal Telegram: t.me/zeilersforum
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 13:18 #1245846

  • brambo
  • brambo's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 7317
Dan zit er wat in de weg van eerdere activiteiten. Oplossing SignalK even opnieuw installeren en vanuit Serial de Ais en de Gps installeren naar SignalK.

heb dit hier ook al eens gehad. Met de herinstallatie van SignalK heb je weer een schone lei gemaakt.

Even kijken in SignalK. Kan zijn dat je al bestaande instellingen er nog instaan.

Kan ook eenvoudig met een browser: adres is dan localhost:3000

Bram
Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 19:16 #1245967

  • lschip
  • lschip's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 945
Zojuist heb ik SignalK opnieuw geïnstalleerd, alle instellingen waren weg.

Maar de foutmelding blijft (Could not locate the bindings file. Tried: → /usr/lib/node_modules/signalk-.

Het logbestand laat het volgende zien:

Alleen ingelogde leden kunnen reageren.

AIS werkt slechter als GPS is ingeschakeld 19 jan 2021 20:14 #1245978

  • baggah
  • baggah's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 121
Ik zou voor de zekerheid dit eerst even proberen op de 32 bit image voor de Pi4. Die is in elk geval wat betreft wifi wat stabieler bij mij.

Heb pas ook de 64 bit versie getest en liep tegen wat problemen aan met openplotter(kplex) en oesenc, die je kan oplossen door er wat verder in te duiken. En eventueel dingen zelf te compileren. Maar het is een eerste keer vaak leuker en makkelijker als het out of the box werkt.
Alleen ingelogde leden kunnen reageren.
  • Pagina:
  • 1
  • 2
Tijd voor maken pagina: 0.311 seconden
Gemaakt door Kunena
   
   
   
   
© Zeilersforum.nl