Welkom  

   

Mijn Menu  

   

What's Up  

Geen evenementen
   

Wedstrijd  

Geen evenementen
   
   
   
   
   
   
   
   
   
   
   
   
   
   
Welkom, Gasten
De mogelijkheden om zelf te knutselen/ontwikkelen met de nieuwste generatie mini-PC's is eindeloos. Omdat er diverse fraaie initiatieven lopen die best wat eigen plek behoeven, bundelen we onze kennis in deze categorie.
  • Pagina:
  • 1
  • 2

Onderwerp: OpenCPN doet niets met ingestelde verbinding

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 07:31 #1194015

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Ik ben thuis aan het spelen met een Rpi met Openplotter/Opencpn. Nu als eerste test een USB gps-muis aan de Rpi gehangen.
Ik sla Openplotter even open en test rechtstreeks in Opencpn. Ik heb een seriele verbinding aangemaakt, waarbij ik de pi user eerst in de dialout groep moest toevoegen.
Via het NMEA debug window zie ik keurig allerlei NMEA sentences verschijnen. Dat lijkt dus goed te gaan. Echter, m'n schip blijft grijs, en ook in de Dashboard plugin zie ik geen gegevens verschijnen over positie en GPS-status.
Doe ik nog iets fout?
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 07:36 #1194018

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
Welke NMEA sentences zie je verschijnen? Als je het debug window even pauzeert dan kun je ze rustig bekijken en kopiëren.
Weet je zeker dat je GPS een fix heeft? Binnen kan dat een tijdje duren.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 07:51 #1194026

  • rooiedirk
  • rooiedirk's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 4175
Inderdaad, de nema sentences goed bekijken, of anders even kopieren en hier posten dan kijken wij even mee.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 08:44 #1194047

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Even een foto van m'n scherm gemaakt, hopelijk is het leesbaar:


Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 08:50 #1194050

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
Niet heel makkelijk te lezen, maar zo te zien zit er geen positie in de RMC berichten?
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 08:51 #1194051

Geen Fix
In je signaal.
Ik natuurlijk wel.

GLL geeft normaal positie en tijd, nu alleen tijd.
Laatst bewerkt: 11 aug 2020 08:54 door It Paradyske.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 09:02 #1194058

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
Leg de GPS muis eens in de vensterbank, of ergens anders waar er zo weinig mogelijk gewapend beton in de weg zit. Waarschijnlijk krijg je dan wel een fix.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 11 aug 2020 09:33 #1194062

  • rooiedirk
  • rooiedirk's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 4175
Weinig aan toe te voegen. Om het wat gemakkelijker te maken kan je een
dashboard maken met de GPS status. Dan krijg je een overzichtje net als op een gps met ingebouwd scherm.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 12 aug 2020 06:52 #1194356

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Was inderdaad geen fix, makkelijk opgelost dus. Bedankt heren!
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 12 aug 2020 08:30 #1194382

Hoewel die suggestie in de titel van de topic gesuggereerd werd, lag het dus niet aan de software van OCPN!
Boot verkocht. Ben na 40 jaar zeilen overgestapt op een "boot op wielen" (caravan).
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 12 aug 2020 08:54 #1194390

  • WADnWIND
  • WADnWIND's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 17215
Aart Korstjens schreef :
Hoewel die suggestie in de titel van de topic gesuggereerd werd, lag het dus niet aan de software van OCPN!

Nee, lag natuurlijk weer eens aan de Fix! ;) :whistle:
Communiceren kost soms geld, niet communiceren kost vaak meer.....

Echte schippers dragen nooit een rode broek.
Laatst bewerkt: 12 aug 2020 08:54 door WADnWIND.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 12 aug 2020 09:07 #1194395

WADnWIND schreef :
Aart Korstjens schreef :
Hoewel die suggestie in de titel van de topic gesuggereerd werd, lag het dus niet aan de software van OCPN!

Nee, lag natuurlijk weer eens aan de Fix! ;) :whistle:

Pas op he! De Fix gaf wel het juiste antwoord.

Snap trouwens niet dat mensen problemen hebben daarmee. Hier altijd een goede Fix.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 24 aug 2020 19:21 #1199061

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Inmiddels heb ik nog wat andere apparaten aan OpenCPN gekoppeld via de multiplexer. Het zijn 3 transducers van Navman. In het debug window zie ik NMEA zinnen verschijnen die zo te zien wel wat waardes bevatten. Onder andere een watertemperatuur van 20.2 graden zie ik op m’n Navman display, en ook in een van de sentences. Maar de Dashboard plugin toont geen waarden bij diepte, wind, of watertemperatuur.
Er kan in dit geval geen sprake zijn van een ontbrekende fix. Maar misschien zijn de zinnen niet correct?

Hierbij een paar foto’s van het debug window:

photos.app.goo.gl/dW9mPGkTfuBDrfUd8

photos.app.goo.gl/3rriy8HsJek9dKQn6
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 24 aug 2020 20:04 #1199085

  • henkvd
  • henkvd's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 3234
Voor watertemp en snelheid door het water, vinkje weg halen bij checksum bij de inkomende compoort.
Zit wel een DPT string in de 2e foto met een checksum, maar die regel bevat geen eenheid van de diepte.
Voor de DBT sentence geldt het zelfde als voor de watertemp en snelheid geen checksum in de nmea sentence, dus vinkje weghalen bij checksum in de poort instellingen bij de ingaande compoort.

DPT string klopt verder eigenlijk ook geen bal van, hadden veel meer komma's in moeten zitten van waardes die ontbreken

$SDDPT,,,1.2,M,,*13 zou een geldige string zijn.
Laatst bewerkt: 24 aug 2020 20:24 door henkvd.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 24 aug 2020 20:53 #1199105

  • rooiedirk
  • rooiedirk's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 4175
Foto1 regel 1 $$VWVLW Heeft ee "$" teveel lijkt verder correct, maar is je logstand en daar doet OpenCPN verder niets mee/
regel 2 $VWMTW watertemperatuur lijkt correct en het ontbreken van de checksum had henk ook al gezien.
regel 3 $$$$$V$PTTKV slaat helemaal nergens op, maar als ik naar de waardes ietsverder in de regel kijkt, lijkt het een beetje of de twee voorgaande regels doorelkaar zijn gehusseld met wat extra verzinsels erbij.
regel 4 (en 5) $VWVHW log snelheid. 4 lijkt goed, maar 5 heeft weer een $ teveel
regel 6 $PTTKV Geen oficieële nmea regel.
........
kortom ook een rommeltje.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 07:00 #1199168

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Checksum verwijderen zal ik proberen, maar hoe komt het dat het zo'n rommeltje is? Heeft Navman z'n eigen interpretatie van NMEA gemaakt? Kan ik er nu nog wat mee als het verwijderen van de checksum het probleem niet oplost?
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 07:04 #1199169

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
Die zinnen die beginnen met een P zijn Proprietary, die kunnen op zich wel kloppen maar alleen de fabrikant weet wat ze betekenen.
Het doorelkaar husselen vind ik heel vreemd. Wat voor multiplexer gebruik je?
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 07:06 #1199171

Wat voor multiplexer heb je, en hoe heb je die aangesloten?
Het lijkt dat het rommeltje uit de mix komt.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 07:36 #1199183

  • 3Noreen
  • 3Noreen's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 6747
Meerdere talker's op één ingang van de multiplexer ?
I am a digitarian. I love to eat my own bytes. Big tech already does enough damage to our society.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 07:55 #1199188

3Noreen schreef :
Meerdere talker's op één ingang van de multiplexer ?

Zat ik ook aan te denken...
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 08:09 #1199192

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
It Paradyske schreef :
3Noreen schreef :
Meerdere talker's op één ingang van de multiplexer ?

Zat ik ook aan te denken...

Zou je denken? Tenzij die talkers op byte-niveau met elkaar gesynchroniseerd zijn, zou ik dan verwachten dat er helemaal niets leesbaars uitkomt. Maar we zijn allemaal benieuwd naar hoe de setup er precies uitziet, dan kunnen we er meer over zeggen.

[Edit bij nader inzien:] Wat er onleesbaar uitkomt valt natuurlijk helemaal weg en zie je niet terug in het opencpn log, dus op die manier zou dit wel door meerdere talkers op een ingang kunnen komen.
Laatst bewerkt: 25 aug 2020 08:16 door Knoet.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 08:23 #1199195

  • XanderB
  • XanderB's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 1313
Ik gebruik de Roosmux, maar juist om te voorkomen dat er allerlei troep in het debug-window zou komen, heb ik alle apparaten verwijderd, en steeds een foto gemaakt als er maar 1 apparaat was aangesloten, zodat ik zeker wist dat alle sentences alleen van dat apparaat afkomstig waren.

Het enige wat ik wel heb gedaan is bij de displays zelf, de Speed uitgang aangesloten op de Wind ingang (conform handleiding, zodat de Navman Wind in staat is de ware wind te berekenen).
Laatst bewerkt: 25 aug 2020 08:25 door XanderB.
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 08:28 #1199196

  • Knoet
  • Knoet's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 883
Een Roosmux heeft zo'n handig diagnosescherm, kun je daar eens een log van posten? (en dan bij voorkeur geen foto maar gewoon tekst, dat leest makkelijker)
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 08:36 #1199198

  • roozeboos
  • roozeboos's Profielfoto
  • aanwezig
  • Gebruiker
  • Berichten: 18579
en je kan een log draaien, dan maakt hij er een bestandje van.
Ontwerper van de RoosMux, en andere apparaatjes.
En sponsor alhier.
www.star-tracking.com www.star-safety.com www.viax.nl

It's been said that a boat is a vessel continually looking for ways to sink itself..
Alleen ingelogde leden kunnen reageren.

OpenCPN doet niets met ingestelde verbinding 25 aug 2020 09:01 #1199206

  • holtere
  • holtere's Profielfoto
  • Offline
  • Gebruiker
  • Berichten: 9428
Of misschien tijd voor een update van de firmware?
"Doe hem een trekschuit
en als bonus de open zee"
J. Ceres jr.
Alleen ingelogde leden kunnen reageren.
  • Pagina:
  • 1
  • 2
Tijd voor maken pagina: 0.240 seconden
Gemaakt door Kunena
   
   
   
   
© Zeilersforum.nl